use strict;
my $str = '8.44.0.39
8.43.0.56
8.44.0.55';
my $regex = qr/^[0-7]\.|^8.([0-3][0-9]|4[0-3]|44.0.([0-3][0-9]))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}