$re = '/^[0-7]\.|^8.([0-3][0-9]|4[0-3]|44.0.([0-3][0-9]))/m';
$str = '8.44.0.39
8.43.0.56
8.44.0.55';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);