const regex = /^[0-7]\.|^8.([0-3][0-9]|4[0-3]|44.0.([0-3][0-9]))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-7]\\.|^8.([0-3][0-9]|4[0-3]|44.0.([0-3][0-9]))', 'gm')
const str = `8.44.0.39
8.43.0.56
8.44.0.55`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}