package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-7]\.|^8.([0-3][0-9]|4[0-3]|44.0.([0-3][0-9]))`)
var str = `8.44.0.39
8.43.0.56
8.44.0.55`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}