import Foundation
let pattern = #"[/(Jan) (\d{1,2})/gi, /(Feb) (\d{1,2})/gi, /(Mar) (\d{1,2})/gi, /(Apr) (\d{1,2})/gi, /(May) (\d{1,2})/gi,/(Jun) (\d{1,2})/gi, /(Jul) (\d{1,2})/gi, /(Aug) (\d{1,2})/gi, /(Sep) (\d{1,2})/gi, /(Oct) (\d{1,2})/gi, /(Nov) (\d{1,2})/gi, /(Dec) (\d{1,2})/gi]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"Tue Jun 08 17:37:41 +0000 2015"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)