const regex = /[/(Jan) (\d{1,2})/gi, /(Feb) (\d{1,2})/gi, /(Mar) (\d{1,2})/gi, /(Apr) (\d{1,2})/gi, /(May) (\d{1,2})/gi,/(Jun) (\d{1,2})/gi, /(Jul) (\d{1,2})/gi, /(Aug) (\d{1,2})/gi, /(Sep) (\d{1,2})/gi, /(Oct) (\d{1,2})/gi, /(Nov) (\d{1,2})/gi, /(Dec) (\d{1,2})/gi]/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\/(Jan) (\\d{1,2})\/gi, \/(Feb) (\\d{1,2})\/gi, \/(Mar) (\\d{1,2})\/gi, \/(Apr) (\\d{1,2})\/gi, \/(May) (\\d{1,2})\/gi,\/(Jun) (\\d{1,2})\/gi, \/(Jul) (\\d{1,2})\/gi, \/(Aug) (\\d{1,2})\/gi, \/(Sep) (\\d{1,2})\/gi, \/(Oct) (\\d{1,2})\/gi, \/(Nov) (\\d{1,2})\/gi, \/(Dec) (\\d{1,2})\/gi]', 'gi')
const str = `Tue Jun 08 17:37:41 +0000 2015`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}