package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[/(Jan) (\d{1,2})/gi, /(Feb) (\d{1,2})/gi, /(Mar) (\d{1,2})/gi, /(Apr) (\d{1,2})/gi, /(May) (\d{1,2})/gi,/(Jun) (\d{1,2})/gi, /(Jul) (\d{1,2})/gi, /(Aug) (\d{1,2})/gi, /(Sep) (\d{1,2})/gi, /(Oct) (\d{1,2})/gi, /(Nov) (\d{1,2})/gi, /(Dec) (\d{1,2})/gi]`)
var str = `Tue Jun 08 17:37:41 +0000 2015`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}