import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[/(Jan) (\\d{1,2})/gi, /(Feb) (\\d{1,2})/gi, /(Mar) (\\d{1,2})/gi, /(Apr) (\\d{1,2})/gi, /(May) (\\d{1,2})/gi,/(Jun) (\\d{1,2})/gi, /(Jul) (\\d{1,2})/gi, /(Aug) (\\d{1,2})/gi, /(Sep) (\\d{1,2})/gi, /(Oct) (\\d{1,2})/gi, /(Nov) (\\d{1,2})/gi, /(Dec) (\\d{1,2})/gi]";
final String string = "Tue Jun 08 17:37:41 +0000 2015";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}