// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)[/(Jan) (\d{1,2})/gi, /(Feb) (\d{1,2})/gi, /(Mar) (\d{1,2})/gi, /(Apr) (\d{1,2})/gi, /(May) (\d{1,2})/gi,/(Jun) (\d{1,2})/gi, /(Jul) (\d{1,2})/gi, /(Aug) (\d{1,2})/gi, /(Sep) (\d{1,2})/gi, /(Oct) (\d{1,2})/gi, /(Nov) (\d{1,2})/gi, /(Dec) (\d{1,2})/gi]").unwrap();
let string = "Tue Jun 08 17:37:41 +0000 2015";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}