import Foundation
let pattern = #"([\W\S]\s[\w\W]{2}.+),\s(.+)\1([!?.])"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Dios mÃo, ¡está aquÃ, está aquÃ, está aquÃ!
¿Qué paso, qué paso?
Me rehúso, me rehúso.
No, no, no, no.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)