# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\W\S]\s[\w\W]{2}.+),\s(.+)\1([!?.])/$1$3/gmi;t' <<< "Dios mÃo, ¡está aquÃ, está aquÃ, está aquÃ!
¿Qué paso, qué paso?
Me rehúso, me rehúso.
No, no, no, no."