using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\W\S]\s[\w\W]{2}.+),\s(.+)\1([!?.])";
string substitution = @"$1$3";
string input = @"Dios mÃo, ¡está aquÃ, está aquÃ, está aquÃ!
¿Qué paso, qué paso?
Me rehúso, me rehúso.
No, no, no, no.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}