$re = '/([\W\S]\s[\w\W]{2}.+),\s(.+)\1([!?.])/mi';
$str = 'Dios mÃo, ¡está aquÃ, está aquÃ, está aquÃ!
¿Qué paso, qué paso?
Me rehúso, me rehúso.
No, no, no, no.';
$subst = "$1$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;