import Foundation
let pattern = #"[1-9]+\.+[0-9]+(e\+|E\+)[2-9]+[0-9]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1.2917967061810938e+20
1.2917967061810938e-20
1.2917967061810938E+20
1.2917967061810938E-20
1.2917967061810938e+20
6.162625864261435e+18
1.232525172852287e+19
10000
.00001
1211.
0.12791
1.20932
10032.02
1.000e-20
1.00e+20
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)