import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[1-9]+\\.+[0-9]+(e\\+|E\\+)[2-9]+[0-9]+";
final String string = "1.2917967061810938e+20\n"
+ "1.2917967061810938e-20\n\n"
+ "1.2917967061810938E+20\n"
+ "1.2917967061810938E-20\n\n"
+ "1.2917967061810938e+20\n"
+ "6.162625864261435e+18\n"
+ "1.232525172852287e+19\n\n"
+ "10000\n\n"
+ ".00001\n"
+ "1211.\n\n"
+ "0.12791\n"
+ "1.20932\n"
+ "10032.02\n\n"
+ "1.000e-20\n"
+ "1.00e+20";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}