// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[1-9]+\.+[0-9]+(e\+|E\+)[2-9]+[0-9]+").unwrap();
let string = "1.2917967061810938e+20
1.2917967061810938e-20
1.2917967061810938E+20
1.2917967061810938E-20
1.2917967061810938e+20
6.162625864261435e+18
1.232525172852287e+19
10000
.00001
1211.
0.12791
1.20932
10032.02
1.000e-20
1.00e+20";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}