#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[1-9]+\.+[0-9]+(e\+|E\+)[2-9]+[0-9]+"
Local $sString = "1.2917967061810938e+20" & @CRLF & _
"1.2917967061810938e-20" & @CRLF & _
"" & @CRLF & _
"1.2917967061810938E+20" & @CRLF & _
"1.2917967061810938E-20" & @CRLF & _
"" & @CRLF & _
"1.2917967061810938e+20" & @CRLF & _
"6.162625864261435e+18" & @CRLF & _
"1.232525172852287e+19" & @CRLF & _
"" & @CRLF & _
"10000" & @CRLF & _
"" & @CRLF & _
".00001" & @CRLF & _
"1211." & @CRLF & _
"" & @CRLF & _
"0.12791" & @CRLF & _
"1.20932" & @CRLF & _
"10032.02" & @CRLF & _
"" & @CRLF & _
"1.000e-20" & @CRLF & _
"1.00e+20"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")