package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[1-9]+\.+[0-9]+(e\+|E\+)[2-9]+[0-9]+`)
var str = `1.2917967061810938e+20
1.2917967061810938e-20
1.2917967061810938E+20
1.2917967061810938E-20
1.2917967061810938e+20
6.162625864261435e+18
1.232525172852287e+19
10000
.00001
1211.
0.12791
1.20932
10032.02
1.000e-20
1.00e+20`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}