// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?im)([<\w\-]+(?:=)?(?:"|')?[\w\-]+(?:"|')?)"#).unwrap();
let string = "<meta charset=\"utf-8\" alone foo=\"tab\"/>
<meta charset2=\"utf-8\"foo2=\"tab\"/>
<meta charset3=\"utf-8\"alone2 foo3=\"tab unclosed/>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}