re = /([<\w\-]+(?:=)?(?:"|')?[\w\-]+(?:"|')?)/im
str = '<meta charset="utf-8" alone foo="tab"/>
<meta charset2="utf-8"foo2="tab"/>
<meta charset3="utf-8"alone2 foo3="tab unclosed/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end