using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([<\w\-]+(?:=)?(?:""|')?[\w\-]+(?:""|')?)";
string input = @"<meta charset=""utf-8"" alone foo=""tab""/>
<meta charset2=""utf-8""foo2=""tab""/>
<meta charset3=""utf-8""alone2 foo3=""tab unclosed/>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}