#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)([<\w\-]+(?:=)?(?:"|')?[\w\-]+(?:"|')?)"
Local $sString = "<meta charset="utf-8" alone foo="tab"/>" & @CRLF & _
"" & @CRLF & _
"<meta charset2="utf-8"foo2="tab"/>" & @CRLF & _
"" & @CRLF & _
"<meta charset3="utf-8"alone2 foo3="tab unclosed/>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")