const regex = /([<\w\-]+(?:=)?(?:"|')?[\w\-]+(?:"|')?)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([<\\w\\-]+(?:=)?(?:"|\')?[\\w\\-]+(?:"|\')?)', 'gim')
const str = `<meta charset="utf-8" alone foo="tab"/>
<meta charset2="utf-8"foo2="tab"/>
<meta charset3="utf-8"alone2 foo3="tab unclosed/>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}