$re = '/<ns2:([^<]*?) xmlns:ns2|<faultstring>([^<]*?)<\/faultstring>/m';
$str = '<env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"><env:Header/><env:Body><env:Fault><faultcode>env:Server</faultcode><faultstring>List "Outage List2" already exists.</faultstring><detail><ns1:ListAlreadyExistsFault xmlns:ns1="http://service.admin.ws.five9.com/"><listName xmlns:ns2="http://service.admin.ws.five9.com/">Outage List2</listName><message>List "Outage List2" already exists.</message></ns1:ListAlreadyExistsFault></detail></env:Fault></env:Body></env:Envelope>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);