import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<ns2:([^<]*?) xmlns:ns2|<faultstring>([^<]*?)<\\/faultstring>";
final String string = "<env:Envelope xmlns:env=\"http://schemas.xmlsoap.org/soap/envelope/\"><env:Header/><env:Body><env:Fault><faultcode>env:Server</faultcode><faultstring>List \"Outage List2\" already exists.</faultstring><detail><ns1:ListAlreadyExistsFault xmlns:ns1=\"http://service.admin.ws.five9.com/\"><listName xmlns:ns2=\"http://service.admin.ws.five9.com/\">Outage List2</listName><message>List \"Outage List2\" already exists.</message></ns1:ListAlreadyExistsFault></detail></env:Fault></env:Body></env:Envelope>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}