use strict;
my $str = '<env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"><env:Header/><env:Body><env:Fault><faultcode>env:Server</faultcode><faultstring>List "Outage List2" already exists.</faultstring><detail><ns1:ListAlreadyExistsFault xmlns:ns1="http://service.admin.ws.five9.com/"><listName xmlns:ns2="http://service.admin.ws.five9.com/">Outage List2</listName><message>List "Outage List2" already exists.</message></ns1:ListAlreadyExistsFault></detail></env:Fault></env:Body></env:Envelope>';
my $regex = qr/<ns2:([^<]*?) xmlns:ns2|<faultstring>([^<]*?)<\/faultstring>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}