using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<ns2:([^<]*?) xmlns:ns2|<faultstring>([^<]*?)<\/faultstring>";
string input = @"<env:Envelope xmlns:env=""http://schemas.xmlsoap.org/soap/envelope/""><env:Header/><env:Body><env:Fault><faultcode>env:Server</faultcode><faultstring>List ""Outage List2"" already exists.</faultstring><detail><ns1:ListAlreadyExistsFault xmlns:ns1=""http://service.admin.ws.five9.com/""><listName xmlns:ns2=""http://service.admin.ws.five9.com/"">Outage List2</listName><message>List ""Outage List2"" already exists.</message></ns1:ListAlreadyExistsFault></detail></env:Fault></env:Body></env:Envelope>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}