package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<ns2:([^<]*?) xmlns:ns2|<faultstring>([^<]*?)<\/faultstring>`)
var str = `<env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"><env:Header/><env:Body><env:Fault><faultcode>env:Server</faultcode><faultstring>List "Outage List2" already exists.</faultstring><detail><ns1:ListAlreadyExistsFault xmlns:ns1="http://service.admin.ws.five9.com/"><listName xmlns:ns2="http://service.admin.ws.five9.com/">Outage List2</listName><message>List "Outage List2" already exists.</message></ns1:ListAlreadyExistsFault></detail></env:Fault></env:Body></env:Envelope>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}