import Foundation
let pattern = #"(?<!Mathf.)(?<=\W)(Cos|Sin|Tan|Asin|Acos|Atan|Sgn|Sqr)(?=\W)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
alpha=(Mathf.Sin(GameTime/1.3f)+1.4f)/2
return Sgn Mathf.Sin(-90+Angle*-1);
Local float AC=v[1]*2 , float AB=v[0]*2 ,float BC=Sqr(AC^2 + AB^2);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Mathf.$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)