import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!Mathf.)(?<=\\W)(Cos|Sin|Tan|Asin|Acos|Atan|Sgn|Sqr)(?=\\W)";
final String string = " alpha=(Mathf.Sin(GameTime/1.3f)+1.4f)/2\n"
+ " return Sgn Mathf.Sin(-90+Angle*-1);\n"
+ " Local float AC=v[1]*2 , float AB=v[0]*2 ,float BC=Sqr(AC^2 + AB^2);";
final String subst = "Mathf.$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}