#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!Mathf.)(?<=\W)(Cos|Sin|Tan|Asin|Acos|Atan|Sgn|Sqr)(?=\W)"
Local $sString = " alpha=(Mathf.Sin(GameTime/1.3f)+1.4f)/2" & @CRLF & _
" return Sgn Mathf.Sin(-90+Angle*-1);" & @CRLF & _
" Local float AC=v[1]*2 , float AB=v[0]*2 ,float BC=Sqr(AC^2 + AB^2);"
Local $sSubst = "Mathf.$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)