re = /(is_granted\()\[(\W.+?)\]/m
str = '"expr(not is_granted([\'SITE_PERMISSION_VIEW_AUDIT_ANSWER_OPTIONS\']) and not is_granted([\'SITE_PERMISSION_CREATE_AUDITS\']) and not is_granted([\'SITE_PERMISSION_CREATE_AUDIT_TEMPLATES\']))",'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result