using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(is_granted\()\[(\W.+?)\]";
string substitution = @"$1$2";
string input = @"""expr(not is_granted(['SITE_PERMISSION_VIEW_AUDIT_ANSWER_OPTIONS']) and not is_granted(['SITE_PERMISSION_CREATE_AUDITS']) and not is_granted(['SITE_PERMISSION_CREATE_AUDIT_TEMPLATES']))"",";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}