$re = '/(is_granted\()\[(\W.+?)\]/m';
$str = '"expr(not is_granted([\'SITE_PERMISSION_VIEW_AUDIT_ANSWER_OPTIONS\']) and not is_granted([\'SITE_PERMISSION_CREATE_AUDITS\']) and not is_granted([\'SITE_PERMISSION_CREATE_AUDIT_TEMPLATES\']))",';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;