use strict;
my $str = '"expr(not is_granted([\'SITE_PERMISSION_VIEW_AUDIT_ANSWER_OPTIONS\']) and not is_granted([\'SITE_PERMISSION_CREATE_AUDITS\']) and not is_granted([\'SITE_PERMISSION_CREATE_AUDIT_TEMPLATES\']))",';
my $regex = qr/(is_granted\()\[(\W.+?)\]/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";