# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(is_granted\()\[(\W.+?)\]/$1$2/gm;t' <<< "\"expr(not is_granted(['SITE_PERMISSION_VIEW_AUDIT_ANSWER_OPTIONS']) and not is_granted(['SITE_PERMISSION_CREATE_AUDITS']) and not is_granted(['SITE_PERMISSION_CREATE_AUDIT_TEMPLATES']))\","