// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ims)(fopen|fwrite)\([^$]*(,|\))").unwrap();
let string = "fopen($file)
fopen($file, 'w')
fopen(\"file\" . $file)
$fp = fopen(
$file
)
$data = base64_encode(fread(fopen($val, \"r\"), filesize($val)));
fopen(\"file\", $w)
fopen(\"file\")
$fp = fopen(
\"file\"
)
$curlResult = fopen(\"/app/localhost/html/curlResult.txt\", \"r\") or die (\"unable to find\");";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}