package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ims)(fopen|fwrite)\([^$]*(,|\))`)
var str = `fopen($file)
fopen($file, 'w')
fopen("file" . $file)
$fp = fopen(
$file
)
$data = base64_encode(fread(fopen($val, "r"), filesize($val)));
fopen("file", $w)
fopen("file")
$fp = fopen(
"file"
)
$curlResult = fopen("/app/localhost/html/curlResult.txt", "r") or die ("unable to find");`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}