$re = '/(fopen|fwrite)\([^$]*(,|\))/ims';
$str = 'fopen($file)
fopen($file, \'w\')
fopen("file" . $file)
$fp = fopen(
$file
)
$data = base64_encode(fread(fopen($val, "r"), filesize($val)));
fopen("file", $w)
fopen("file")
$fp = fopen(
"file"
)
$curlResult = fopen("/app/localhost/html/curlResult.txt", "r") or die ("unable to find");';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);