const regex = /(fopen|fwrite)\([^$]*(,|\))/gims;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(fopen|fwrite)\\([^$]*(,|\\))', 'gims')
const str = `fopen(\$file)
fopen(\$file, 'w')
fopen("file" . \$file)
\$fp = fopen(
\$file
)
\$data = base64_encode(fread(fopen(\$val, "r"), filesize(\$val)));
fopen("file", \$w)
fopen("file")
\$fp = fopen(
"file"
)
\$curlResult = fopen("/app/localhost/html/curlResult.txt", "r") or die ("unable to find");`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}