using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(fopen|fwrite)\([^$]*(,|\))";
string input = @"fopen($file)
fopen($file, 'w')
fopen(""file"" . $file)
$fp = fopen(
$file
)
$data = base64_encode(fread(fopen($val, ""r""), filesize($val)));
fopen(""file"", $w)
fopen(""file"")
$fp = fopen(
""file""
)
$curlResult = fopen(""/app/localhost/html/curlResult.txt"", ""r"") or die (""unable to find"");";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}