$re = '/(\d+)?(d\d+)?(dl\d+)?(dh\d+)?/m';
$str = '1d5
d7
5
7d5dl2
6d1dh4
d1dl9dh1
4dl1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);