const regex = new RegExp('(\\d+)?(d\\d+)?(dl\\d+)?(dh\\d+)?', 'gm')
const str = `1d5
d7
5
7d5dl2
6d1dh4
d1dl9dh1
4dl1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}