#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+)?(d\d+)?(dl\d+)?(dh\d+)?"
Local $sString = "1d5" & @CRLF & _
"d7" & @CRLF & _
"5" & @CRLF & _
"7d5dl2" & @CRLF & _
"6d1dh4" & @CRLF & _
"d1dl9dh1" & @CRLF & _
"4dl1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")