using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)?(d\d+)?(dl\d+)?(dh\d+)?";
string input = @"1d5
d7
5
7d5dl2
6d1dh4
d1dl9dh1
4dl1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}