package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)?(d\d+)?(dl\d+)?(dh\d+)?`)
var str = `1d5
d7
5
7d5dl2
6d1dh4
d1dl9dh1
4dl1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}