re = /\[url]https:\/\/(?:www\.)*+youtube\.com\/watch\?v=([\w\-]+)\[\/url\]/i
str = '[url]https://www.youtube.com/watch?v=hXxQhbmjE7o[/url]'
subst = '[media=youtube]\\1[/media]'
result = str.sub(re, subst)
# Print the result of the substitution
puts result