$re = '/\[url]https:\/\/(?:www\.)*+youtube\.com\/watch\?v=([\w\-]+)\[\/url\]/Uis';
$str = '[url]https://www.youtube.com/watch?v=hXxQhbmjE7o[/url]';
$subst = "[media=youtube]\1[/media]";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;