import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[url]https:\\/\\/(?:www\\.)*+youtube\\.com\\/watch\\?v=([\\w\\-]+)\\[\\/url\\]";
final String string = "[url]https://www.youtube.com/watch?v=hXxQhbmjE7o[/url]";
final String subst = "[media=youtube]\\1[/media]";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS | Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}