package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?Uis)\[url]https:\/\/(?:www\.)*+youtube\.com\/watch\?v=([\w\-]+)\[\/url\]`)
var str = []byte(`[url]https://www.youtube.com/watch?v=hXxQhbmjE7o[/url]`)
var substitution = []byte("[media=youtube]\1[/media]")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}